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3.1 Office Applications – Word Processing 

3.1.1 Understanding Microsoft Office Word 

3.1.1.1 The Microsoft Office Button 

The Microsoft Office Button  is located in the upper –left corner of the following Microsoft Office 

system programs: Word, Excel, PowerPoint, Access, and Outlook (as shown in Figure 1). When you 

click the Office Button you see the same basic commands available on the file menu in earlier 

releases of Microsoft Office to open, save and print your file.  

 

Figure 1: Microsoft Word Basic Buttons  

3.1.1.2 The Quick Access Toolbar  
The Quick Access Toolbar (shown in Figure 2) appears at the top of the Access window and provides 

you with one-click shortcuts to commonly used functions. You may customize the contents of the 

toolbar by clicking the “down” arrow icon immediately to the right of the toolbar.  

 

Figure 2: The Quick Access Toolbar 

By default, the Quick Access Toolbar contains buttons for Save, Undo and Redo. You may customize 

the toolbar by adding icons for New, Open, E-mail, Print, Print Preview, Spelling, Mode, Refresh All 

and other functions. 

3.1.1.3 The Title Bar  
The title bar is a horizontal bar at the top of an active document. This bar displays the name of the 

document and application. At the right end of the Title Bar are the Minimize, Restore and Close 

buttons. 
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3.1.1.4 The Ribbon 
The ribbon is an area across the top of the screen that allows access to almost all the functionality of 

Word from a single area. The Ribbon replaces the menus and toolbars in previous versions. The 

Ribbon exposes most of the features that used to be hidden in File menus. It makes it easier to see 

and find commands to format and edit your document. The Ribbon can be reduced to a single line of 

tabs by pressing CTRL + F1 or by double-clicking on the active tab. 

3.1.1.5 The Ruler 
The Ruler feature in Microsoft Word is useful for positioning selections of text within a document.  

You may use Ruler in order to adjust margins, indents and place tab stops around which you position 

your text. In Word 2007, the ruler is hidden by default, so you must show it while in Print Layout view 

(as in Figure 3).  With Classic menu for Word 2007 or 2010 installed, you can click Menus tab. Then 

you have to  

1. Click View Menu  
2. Choose Ruler in the drop down menu  
3. Then you will see the horizontal and vertical ruler appearing in the document: 

 

 

Figure 3: The Ruler feature of Microsoft Word 

3.1.1.6 The Text Area 
The text area is the main window corresponding to the printed page. You type your document in the 

text area. The blinking vertical line in the upper-left corner of the text area is the cursor. Figure 4 

shows the text area in Microsoft Word (¶ is the paragraph symbol). A flashing vertical bar  marks the 

current insertion point. As you type, your text displays at the cursor location. The horizontal line next 

to the cursor marks the end of the document.  
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Figure 4: The Text Area in Microsoft Office 

The Status BarFigure 5 shows the Status Bar Menu. You can change what displays on 

the Status bar by right-clicking on the Status bar and selecting the options you want from the 

Customize Status Bar menu. 

 
Figure 5: The Status Bar Menu in Microsoft Word 
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3.1.1.7 Documents Views  
In Word, you can display your document in one of five views: Draft, Web Layout, Print Layout, Full 

Screen Reading, or Online Layout.  

1. Draft View: You use Draft view to quickly edit your document (images are not displayed). 
2. Web Layout: Web Layout view enables you to see your document as it would appear in a 

browser such as Internet Explorer. 
3. Print Layout: The Print Layout view shows the document approximately as it will look when it 

is printed. 
4. Reading Layout: Reading Layout view formats your screen to make reading your document 

more comfortable. 
5. Outline View: Outline view displays the document in outline form. You can display headings 

without the text. If you move a heading, the accompanying text moves with it. 

3.1.1.8 Nonprinting Characters 
Certain characters, called non-printing characters, do not print and will not appear in your printed 

document but do affect your document layout. For example, in Figure 6, number 1 shows the Home 

page features and number 2 shows the paragraph mark (¶). Clicking this paragraph mark button 

toggles between the paragraph marks being visible or hidden on the screen view. 

 

Figure 6: Nonprinting Characters in Microsoft Word 

3.1.1.9 Create Sample Data and Select Text  
If you type =rand() in your Word document and then press Enter, Word creates three “canned-text” 

paragraphs. You can use these paragraphs to practice what you learn. 

3.1.1.10 Place the Cursor  
You can move the cursor to the specified location by left clicking with the mouse, or using the arrow 

keys to move to the specified location.  

3.1.1.11 Execute Commands with Keyboard Shortcuts  
When using Word you can accomplish tasks through a variety of methods. The most common one is 

to choose an option by clicking the option on the Ribbon. However, you can also use shortcut keys. A 

key name followed by a plus and a letter means to hold down the key while pressing the letter. 
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3.1.2 Microsoft Office Word Basic Functionality 

3.1.2.1 Type, Backspace, and Delete  
In Microsoft Word, you create documents by typing them. For instance, to create a new file you open 

Microsoft Word and then begin typing. When your text reaches the end of a line, Microsoft Word 

moves your text to a new line. If you want to start a new paragraph then press enter. If you want to 

delete, use the Backspace key. Each time you press the Backspace key, Microsoft Word deletes the 

character that precedes the insertion point. The insertion point is the point at which your mouse 

pointer is located. Another way to delete text is to use the Delete Key by selecting firstly the text you 

want to select and then to press the Delete Key. If you hold the backspace key it will delete letters 

one at a time until it is released. 

3.1.2.2 Insert and Overtype  
Insert mode inserts text in between the text behind and the text in front of the insertion point. 

Overtype mode will type letters over letters that are already in front of the insertion point. 

In order to place an insert/overtype button on the Status bar you may follow the steps below: 

1. Right-click the Status bar. The Customize Status Bar menu appears. 
2. Click Overtype. The Insert/Overtype button appears on the Status bar. 
3. If the word Insert appears on the Status bar, you are in Insert mode. 
4. If the word Overtype appears on the Status bar, click the word Overtype and it will change to 

Insert, thereby changing Word to Insert mode. 

3.1.2.3 Save a File and Close 
If you want to recall your document and/or documents later you have to save them by using the Save 

Option on the Microsoft Office menu. Another alternative for saving a document is by typing Ctrl+s. 

When you save a document for the first time, a dialog box with the name “Save As” appears. You can 

use this dialog box to locate your document in the folder that you prefer and to give your document 

a name. After you have saved your document at least once, you can save any changes by clicking the 

“Save”.  

3.1.2.4 Open a File  
Suppose that you don’t have time to complete your work, you have to save it and close the file. Later 

you can open it to revise or finish it. More specifically, in order to open the file that you have saved 

you have to follow the next steps:  

1. Open Word 2010. 
2. Click the Microsoft Office button. A menu appears. 
3. Click “Open”. The “Open dialog” box appears. 
4. Use the “Look In” field to move to the folder in which you saved the file. The file is named 

“Lesson Two.docx”. 
5. Click “Lesson Two.docx”. 
6. Click “Open". The file you created during the previous lesson appears. 
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An alternative method to open a file is to use keys, namely to press Ctrl+o, or to double click on the 

file in Windows Explorer. 

3.1.2.5 Cut and Paste  
You can remove information from a document and place it anywhere in the same or different 

documents through the “Cut and Paste” features.  The Office Clipboard is a storage area. When you 

cut, Word stores the data you cut on the Clipboard. You can paste the information that is stored on 

the Clipboard as often as you like.  

3.1.2.6 Use the Clipboard 
Each time you cut or copy Word stores hierarchically this information on the Clipboard. When you 

choose “Paste”, the item at the top of the hierarchy is the item Word pastes into your document. The 

Clipboard can store up to 24 items. You can paste any item on the Clipboard into your document by 

placing your cursor at the insertion point, displaying the Clipboard pane, and then clicking the item. 

The Clipboard pane includes an Options button. You can click the Options button to set the Clipboard 

options described in Table 1. 

Option Description 

Show Office Clipboard Automatically Shows the Clipboard automatically when you 
copy items. 

Show Office Clipboard When Ctrl+c 
Pressed Twice 

Shows the Clipboard when you press Ctrl+c twice. 

Collect Without Showing Office 
Clipboard 

Copies to the Clipboard without displaying the 
Clipboard pane. 

Show Office Clipboard Icon on Taskbar Displays the Clipboard icon on your system 
taskbar. 

Show Status Near Taskbar When 
Copying 

Displays the number of items copied on the 
taskbar when copying. 

Table 1: The clipboard pane functionality in Microsoft Word 

3.1.2.7 Use Spell Check  
As you type Word checks your spelling and grammar. Spelling errors display with a red wavy line 

under the word. Grammar errors display with a green wavy line under the error. Word 2007 provides 

you with the potential to review the spelling and grammar errors of your documents by using the 

Review tab’s Spelling & Grammar button. 

3.1.2.8 Find and Replace 
If you are working with large files and want to search for single words, you can use the Find 

command. Executing this command you will find particular words or phrases in your document. 

However, if you want to limit your search to a selected area, select that area and then execute the 

Find command.  
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3.1.2.9 Change Text Formatting  
This feature allows you to change the font type at the insertion point of the document or, indeed, to 

change the font for any amount of selected text (as it is shown inFigure 7).  

This enables you to give the text in your documents different looks and styles. To change the font 

size or type: 

1. Select the text to which you wish to apply a different font. This can be any amount of text in 

the document from a single character, a word, a sentence, a paragraph, or the entire 

document. 

2. A quick way to change the font type or size is to use the icons on the Formatting toolbar (use 

a right click to display this) 

 
Figure 7: Text Formatting in Microsoft Word 

3.1.2.10 Using the Font Dialog Box 
From the Format menu, choose the Font command as it is shown in Figure 8. The Font dialog box is 
displayed. 
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Figure 8: The Font Command 

 Font: Also called a typeface, specifies the overall look of the character set. 

 Font Style: Determines the emphasis given to a character, i.e. Bold or Italic. 

 Size: Determines the size of the character in points. 

 Underline: Determines underlining style. 

 Color: Determines the colour of the text. 

 Strikethrough: A strikethrough line is drawn through selected characters. 

 Double Strikethrough: Two strikethrough lines are drawn through selected characters. 

 Superscript: Text is raised above its normal position on the text line. 

 Subscript: Text is lowered below its normal position on the text line. 

 Shadow: Adds a shadow behind the text. 

 Outline: Displays the inner and outer borders of each character. 

 Emboss: Text appears to be raised off the page in relief. 

 Engrave: Text appears to be printed or pressed into the page. 

 Small caps: Text is formatted in small capital letters. 

 All Caps: All text is formatted in capital letters. 

 Hidden: Characters are hidden on the page. 
 

3.1.2.11 Apply Text Formatting  
To format selected text as bold, italic or underline you have to: 

1. Select the text you wish to format as bold, italic or underline. 

Click on the Bold or Italic icon ( ) or the underline icon ( ) in the Formatting toolbar 

To switch off the selected format re-click on the corresponding icon in the Formatting toolbar. 
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3.1.2.12 Preview & Print 
The Print Preview feature is useful for viewing your document prior to printing. You can also print 
directly from the Print Preview screen. To Print Preview a document the next steps should be 
followed:  

1. Click on the Office button 
2. In the Preview and print the document submenu, click PRINT PREVIEW 
3. To return to your document without printing, on the Print Preview command tab, click CLOSE 

PRINT PREVIEW (Print Preview closes). 
4. To print, on the Print Preview command tab, in the Print group, click PRINT 
5. From the Name pull-down list, select the desired printer 
6. In the Page range and Copies sections, make the desired selections  
7. To print your document, click OK 

3.1.3 LibreOffice Writer  
LibreOffice Writer is a word processor with similar functionality and file support to Microsoft Word 

or WordPerfect. Writer is a feature-rich tool for creating letters, books, reports, newsletters, 

brochures, and other documents. You can insert graphics and objects from other components into 

Writer documents. Writer can export files to HTML, XHTML, XML, Adobe’s Portable Document 

Format (PDF), Daisy and Braille and several versions of Microsoft Word files. 

 To launch Writer as it is shown in Figure 9, you have to go to the LibreOffice Start Center and select 

“Text Document”.  

 

Figure 9: Launching Writer 

http://www.uwec.edu/help/word07/basics.htm#default#default
http://en.wikipedia.org/wiki/Word_processor
http://en.wikipedia.org/wiki/Microsoft_Word
http://en.wikipedia.org/wiki/WordPerfect
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If you need to create a new document you have to launch Writer and a blank document is created, 

temporarily named Untitled1 as it is shown in Figure 10.  For a new document you have to go to 

File>New in the menu bar and it will be created and automatically named Untitled2 (). You can 

repeat this as many times as new documents you need (Figure 11).  

 

Figure 10: Creating new documents in LibreOffice 

 

Figure 11: Creating multiple documents in LibreOffice 
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In this new document as it shown in Figure 12 you can type text and apply different formats to it by 

using the tools seen on the toolbars and in the menus: bold (Figure 13), italics, underlined, font 

colour and different types of alignment.  

 

Figure 12: A new document in LibreOffice 

 

Figure 13: Applying different formats (bold in the example) in LibreOffice 

Suppose that after you finished creating or editing a document you want to save it. Go to File →Save. 

An explorer like dialog will open as it is shown in Figure 14 
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Figure 14: Saving a document in LIbreOffice 

Here you can browse for a location and enter a name. A wide variety of formats like .doc, .txt and the 

native .odt. are provided. Additionally another saving option is provided: “Save as” that it will take 

you to an explorer like dialog again where you can browse to the folder where you want to store the 

copy of your document (Figure 15).  

 

Figure 15: The “Save As” option in LibreOffice 
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To insert an image to a document, go to the LibreOffice Start Office and select “Text Document” as it 

has already illustrated in Figure 9. Now open or create the new document where you want to insert 

the image. The next step is to Insert →Picture→From File as it is shown in Figure 16.  

 

Figure 16: Inserting an image in LibreOffice 

The Insert picture dialog will open and you can select the image file you want to insert. Browse to it, 

select it and then click Open. 

 

Figure 17: The insert picture dialog 
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3.2 Office Applications – Spreadsheets 

3.2.1 Microsoft Office Excel Basics 
A Workbook is a very large table consisting of rows and columns where data can be entered is called 

a worksheet as it is shown in Figure 18. Worksheets in turn are grouped together into workbooks. By 

default each workbook in Excel contains 3 worksheets, which are identified by tabs displayed along 

the bottom of the screen. These identify the individual worksheets making up the workbook. By 

default the first worksheet is called Sheet1, the next is Sheet2 and so on. 

 

Figure 18 : The worksheet in Microsoft Office Excel 

To start Excel () using the Windows Start menu: 

1. Click on the Start icon to display the Start menu and then move the mouse pointer onto All 
Programs. 

2. From the sub-menu select Microsoft Excel. 

 

Figure 19:  Starting Microsoft Excel 

There are several choices to quit Excel (to shut down the program): 

1. Click the Office button followed by the Exit Excel button. 
2. Press Alt+ F4 function key. 

Click on the Excel Close icon  
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To open an existing workbook from the File menu, choose “Open”, or click on the “Open” icon on the 

Standard toolbar.  

To close a working workgroup, select Close from the File menu. Note that: You will be asked if you 

wish to save any changes you have made to the file. Select Yes to save, or No to ignore the changes 

(Figure 20). 

 
Figure 20: Saving files in Microsoft Word 

3.2.1.1 Columns  
To create a type of list like the above, Microsoft Excel provides a ready-made arrangement of 

columns. To easily identify each category of the list, a column is created as a vertical object. On top of 

each column, there is a (blue) bar called the column header as it is shown in Figure 21. As seen in the 

previous lesson, the columns are organized as a row of (blue) bars: 

 

Figure 21:  Organised columns in Microsoft Excel 

To distinguish each column, it has a name. The name of a column displays in the column header. The 

name uses one, two, or three letters. The leftmost column is labelled, A. The second has a label of B, 

and so on. 

3.2.1.2 Rows 
Like the columns, each row is labelled with numbers starting at the top with 1. These labels show on 

small boxes on the left side of the Microsoft Excel interface (Figure 22). Each box that shows the label 

of a row is called a row header: 
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Figure 22: Labelled rows in Microsoft Excel 

3.2.1.3 Cells 
Each cell can be identified by its column letter and row number (Figure 23). The selected cell is 

shown with a bold outline and the column and row headers highlighted in yellow. 

 

Figure 23:  A spreadsheet showing cell B9 selected 

http://excel.tutorialib.com/wp-content/uploads/2011/07/You-can-use-a-range-intersection-formula-to-determine-values.png
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3.2.2 Formatting Spreadsheet Data  

3.2.2.1 Enter Numbers  
 

1. Select the cell in which you want to enter a number and type in the number. If you want to 
make the number a negative, type a minus sign in front of it or enclose it in parentheses (i.e. 
brackets). 

2. To indicate decimal places, you type a full stop or a comma depending on the settings. 
3. The numbers will be right aligned by default. If you wish to enter a number or formula as 

text, type an apostrophe (') before it. 

3.2.2.2 Enter Dates or Times 
1. Select the cell in which you want to enter the date or time and then type in the date or time. 

Separate the date with either hyphens or slashes 
2. To enter the current date use the key stroke CTR+SEMICOLON while to enter the current 

time, use the keystroke CTRL+SHIFT+SEMICOLON 

3.2.2.3 Enter Text Into a Cell 
1. Simply click on the cell and start typing the text which you wish to appear in that cell 
2. To move to the next cell use the Tab key. To move down a cell press the Enter key. 

3.2.2.4 Formatting Data  
Insert additional cell content, replace existing cell content 

Click on the cell containing the data which you wish to change. In the example shown (Figure 24), we 

have clicked on cell A2 containing the text Accounts for 2002. 

 

Figure 24: Changing the data in cell content 

If we wanted to change the data in the selected cell from Accounts for 2002, to Accounts for 2003, 

we have two alternatives: 

1. Click in the editing bar towards the top of your screen, where you will see the contents of the 

selected cell duplicated and there you can make your changes, or 

2. Double click in “place editing” on the cell containing the data which you wish to edit, and 

then edit the data directly within that cell. 

Replace existing cell contents 
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1. Click on the cell contents which you wish to replace.  

2. Type in the new data and the data you enter will automatically replace the existing contents. 

Add borders 

To apply a border to a cell range as it is shown in Figure 25 (use the Border icon): 

1. Select the cell(s) to which you want to add a border (by dragging with the mouse or using 
shift with the arrow keys) 

2. To view border options, click on the down arrow next to the Borders icon on the Formatting 
toolbar 

3. Select the option you require. Once you have added a border using the Borders icon, the 
border you selected will appear on the Borders icon. You can add the same border simply by 
clicking on the icon after you have selected the cell(s) to which you wish to apply the border. 

 

 

Figure 25: Apply borders to a cell range 

Create different types of charts/graphs from spreadsheet data 

Select the cells you want to include in a chart. If you want to highlight a non-contiguous range, 

highlight the first range with the mouse, and hold down the Ctrl key and click on any other cells. 

On the Insert toolbar, click on the required Chart icon (from column, line, pie, bar, area, scatter and 

other) (Figure 26). Or click the small arrow at the bottom of the charts section of the insert ribbon to 

reveal the dialogue in Figure 27. 

        

Figure 26: Chart icons in the Insert menu 
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Figure 27: The Chart type feature 

You can then edit the chart using the settings in the Design, Layout and Format tabs of the Chart 

Tools as shown in Figure 28 to Figure 30. 

 

Figure 28: The design tab 
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Figure 29: The Layout tab 

 

Figure 30: The Format tab 

These tabs provide all the functionality to fully edit the charts. 

3.2.2.5 Manage Basic Equations 
Generate formulae 

To generate formulas using cell references and arithmetic operators: 

1. Place the cursor in the cell where the formula will appear. 
2. Enter an “=” (equal) sign. 
3. Enter the expression which will produce the result you want. This can consist of operands, 

values, variables, and symbols which represent mathematical procedures (such as “=A5+E5” 
for adding the content of cell A5 with E5). 

 
You can use the following symbols: 
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When the formula is complete, press Enter. The result of the formula will be calculated and displayed 

in the cell. 

You can display the formula itself in the Formula bar at the top of the screen by placing the cell 

pointer on the cell. If there is an error in a formula, an error message is displayed which will begin 

with a # sign. 

Enter a cell or range reference by pointing  

1. Enter the formula up to the point of the cell or range reference, e.g. to enter the formula 
=E2+E5, only enter the equal (=) sign. 

2. Move the cell pointer to the first cell reference using the arrow keys. The formula will track 
your progress and enter the current address into the formula. 

3. Press Enter to complete the formula when you have reached the cell you require. 
 

3.2.3 LibreOffice Calc  
Calc, is the spreadsheet component of LibreOffice (Figure 31), similar to Microsoft Excel or Lotus 1-2-

3. It has a number of unique features, including a system which automatically defines series of 

graphs, based on information available to the user. 

 

Figure 31: The spreadsheet of LibreOffice 

To open Calc you have to select the “Spreadsheet” from the options. The main components of Calc: 

contain a gird of cells, the tools organized in toolbars, the menus in the menu bar and the sheet 

labels.   

http://en.wikipedia.org/wiki/Microsoft_Excel
http://en.wikipedia.org/wiki/Lotus_1-2-3
http://en.wikipedia.org/wiki/Lotus_1-2-3
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Figure 32: The main components of Calc in LibreOffice 

The Format Cells dialog box is very important because it provides you with the options to apply the 

“Date” format and all numerical data will be treated as date in the selected format. 

 

Figure 33: The Format Cells dialog box 

Other features provided by Calc include: 

 Functions, which can be used to create formulas to perform complex calculations on data 

 Database functions, to arrange, store, and filter data 

 Dynamic charts; a wide range of 2D and 3D charts 

 Macros, for recording and executing repetitive tasks; scripting languages supported include 
LibreOffice Basic, Python, BeanShell, and JavaScript 

 Ability to open, edit, and save Microsoft Excel spreadsheets 
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 Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and 
PostScript 

When Calc is started, the main window looks similar to Figure 31. More specifically:  

The Title bar located at the top, shows the name of the current spreadsheet. When the spreadsheet 

is newly created, its name is Untitled X, where X is a number. When you save a spreadsheet for the 

first time, you are prompted to enter a name of your choice. 

Under the Title bar is the menu bar. When you choose one of the menus, a submenu appears with 

other options.  

 File contains commands that apply to the entire document such as Open, Save, Wizards, 
Export as PDF, and Digital Signatures. 

 Edit contains commands for editing the document such as Undo, Changes, Compare 
Document, and Find and Replace. 

 View contains commands for modifying how the Calc user interface looks such as Toolbars, 
Full Screen, and Zoom. 

 Insert contains commands for inserting elements such as cells, rows, columns, sheets, and 
pictures into a spreadsheet. 

 Format contains commands for modifying the layout of a spreadsheet such as Styles and 
Formatting, Paragraph, and Merge Cells. 

 Tools contains functions such as Spelling, Share Document, Cell Contents, Gallery, and 
Macros. 

 Data contains commands for manipulating data in your spreadsheet such as Define Range, 
Sort, Filter, and DataPilot. 

 Window contains commands for the display window such as New Window, Split, and Freeze. 

 Help contains links to the Help file bundled with the software, What's This?, Support, 
Registration, and Check for Updates.  

Calc has several types of toolbars: docked (fixed in place), floating, and tear-off. Docked toolbars can 

be moved to different locations or made to float, and floating toolbars can be docked. Four toolbars 

are located under the Menu bar by default: the Standard toolbar, the Find toolbar, the Formatting 

toolbar, and the Formula Bar. 

Displaying or hiding toolbars: To display or hide toolbars, choose View → Toolbars, then click on the 

name of a toolbar in the list. An active toolbar shows a check mark beside its name. Tear-off toolbars 

are not listed in the View menu. 

Palettes and tear –off toolbars: Toolbar icons with a small triangle to the right will display palettes, 

tear-off toolbars, and other ways of selecting things, depending on the icon. An example of a palette 

is shown in the figure below:  

 

Figure 34: An example of a palette in LibreOffice Calc 
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Moving toolbars:To move a docked toolbar, place the mouse pointer over the toolbar handle, hold 

down the left mouse button, drag the toolbar to the new location, and then release the mouse 

button Figure 35. To move a floating toolbar, click on its title and drag it to a new location Figure 36.  

 

Figure 35: Moving Toolbars in Calc 

 

Figure 36: Moving a floating toolbar 

Docking/floating windows and toolbars: Toolbars and some windows, such as the Navigator and the 

Styles and Formatting window, are dockable. You can move, resize, or dock them to an edge. 

To dock a window or toolbar, hold down the Control key and double-click on the frame of the 

floating window.  

To undock a window, hold down the Control key and double-click on the frame (or a vacant area near 

the icons at the top) of the docked window. 

 

Figure 37: The Navigator window 

Customizing toolbars: To access a toolbar’s customization options, use the down-arrow at the end of 

the toolbar or on its title bar.  
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Figure 38: Customizing toolbars 

You can also add icons and create new toolbars:  

 

Figure 39: Selection of visible toolbar icons 

Formatting toolbar: In the Formatting toolbar, the three boxes on the left are the Apply Style, Font 

Name, and Font Size lists  

 

Figure 40: The Formatting Toolbar 
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3.3 Office Applications – Slideshow Presentation 

Software 

3.3.1 How to Use Microsoft Office PowerPoint 
PowerPoint is a presentation software that can be used to create slide shows for printing, on-screen 

projection or Web-based display.  

3.3.1.1 Opening PowerPoint 
1. Click on the Start Button 
2. Click on All Programs 
3. Click on Microsoft Office & then Microsoft PowerPoint option 

 

 
 

Figure 41: Opening Microsoft PowerPoint 

3.3.1.2 Closing PowerPoint 
1. Click on the Close icon (the small cross at the top-right of the application window). If unsaved 

changes have been made to your presentation a dialog box is displayed, giving you the 
chance to save the presentation as it is shown in Figure 42, prior to closing the program. 

 

 

Figure 42: Save the PowerPoint presentations 

2. Click Yes to save the presentation before closing OR click No to close without saving changes 
OR click on the Cancel button to cancel the operation. 
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3.3.1.3 Creating a New Presentation 
Start PowerPoint. When PowerPoint is opened, a blank Title slide appears by default as the first slide 

in your new presentation. This blank Title slide is the basis for your new presentation when you first 

open PowerPoint or after PowerPoint is already open (Figure 43). 

Alternatively, you could click on the new icon. 

 

Figure 43: Creating Presentations in PowerPoint 

3.3.1.4 Opening an Existing Presentation 
Click the Office button and then the Open menu selection. The Open dialog box is displayed. If the 

file you want to open is contained in another folder or drive, move to that location using the Look in: 

list box. To open the file you require, click on the file to select it and then click on the Open button. 

You can use the icons across the top of the Open dialog box to help you in locating and selecting the 

required file (Figure 44). 

 

Figure 44: Locating and selecting files 

Click on the Down arrow to display folders (directories) and drives. 

 Display previous folders. 
 Click here to move up one folder level in the directory tree. 

Click here to search the Web. 
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Click here to delete the selected file. 

Click here to create a new folder under the selected folder. 

Click on the drop down arrow next to the icon to see a list of selectable views. 
Repeatedly clicking on this icon will cycle through the various views. 
 

 

Figure 45: The list of Tools selectable views 

To open a recently used PowerPoint file, you have to select a list of recently opened files under the 

Office button. You can open these files by clicking on them.  

 

Figure 46: Open a recently used PowerPoint files 

3.3.1.5 Add Title and Subtitle to a Presentation  
When you first open PowerPoint, you will see a blank “slide” with a space for a title and a subtitle in 

two boxes. This page will be the basis in order to create your presentation. You can put a title and 

subtitle in the boxes if you want to by clicking inside and typing but you could delete them and insert 

anything you want. 
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Figure 47: A Title and a Subtitle of a Presentation 

3.3.1.6 Edit Slide Content 
To edit slide content you have to use the same editing techniques which you would use within a 

word-processor. To insert text you have to click at the point you wish to insert text and start typing.  

If you want to overwrite existing text, select the text you wish to replace with new text.  Start typing 

and the new text will replace the old text. 

To edit notes pages, use the same techniques as above, and edit the notes text which is displayed 

under the slide in Normal View. 

To insert an image into a slide you have to: 

 Display a slide within your presentation. 

 Click on the Insert tab menu, select the Picture command. If necessary change to the 
required drive or folder and then select the required picture file. You should see a preview of 
the selected picture file within the dialog box. 
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Figure 48: Insert an image to your presentation 

Once the correct file is selected, click on the Insert button and the picture will be displayed within 

your slide. 

Note that if you click on the down arrow in the Files of type section of the Insert Picture dialog box, 

you will see a list of file types which you can insert into your presentation. 

 

Figure 49: Different file types where you can insert your presentation 

You can copy, move and delete images in almost exactly the same way that you would manipulate 

selected text. You can use drag and drop techniques or use the Clipboard, along with the Cut, Copy 

and Paste commands. 

To copy and paste an image you have to:  
 

 Select the image you wish to copy to the Clipboard 

 Then from the Edit menu select the Copy command OR press Ctrl+C, to move the image to 
the Clipboard without removing it from the slide OR you can also use the Copy icon on the 

Standard toolbar    
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Once the image is stored within the Clipboard, position the insertion point within a slide, at the 

position where you wish to paste the image. Then click on the Paste icon . Moreover to copy an 

item from one slide to another within a presentation  

 Select the text, image, drawn object, or chart which you wish to copy. 

 Press Ctrl+C to copy the selected item to the Clipboard. 

 Use the Next slide/Previous slide controls to display the slide to which you wish to copy the 
item. 

 

Figure 50: The Next Slide icon 

If the item you copied to the Clipboard was text, then click within the slide at the location where you 

wish to paste the text, or else simply paste the item into the slide. Remember that the keyboard 

shortcut to paste is Ctrl+V. If the item was not text, you may have to use the normal 'drag and drop' 

techniques to move the item within the slide. 

To copy an item from a slide in one presentation to a slide within a different presentation:  

 Select the text, image, drawn object, or chart which you wish to copy. 

 Press Ctrl+C to copy the selected item to the Clipboard. 

 Select the other, open PowerPoint presentation, to which you wish to paste the copied item. 
 
If necessary, within this second presentation, use the Next slide/Previous slide controls to display the 

slide to which you wish to copy the item. 

If the item you copied to the Clipboard was text, then click within the slide at the location where you 

wish to paste the text, or else simply, paste the item into the slide. Remember that the keyboard 

shortcut to paste is Ctrl+V. If the item was not text, you may have to use the normal 'drag and drop' 

techniques to move the item within the slide. 

To copy a slide from one place to another within a presentation:  

 Click on the Slide Sorter View icon  

 Select the slide which you wish to copy. 

 Press Ctrl+C to copy the entire slide to the Clipboard. 

 Click between the two slides where you wish to paste the copied slide (a thin vertical line 
marks the insertion point for you) 

 Press Ctrl+V to paste the copied slide. 

 

Figure 51: The Slide Sorter View 
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To copy a slide within one presentation to a slide within a different presentation:  

 Click on the Slide Sorter View icon (bottom-left) 

 Select the slide which you wish to copy. 

 Press Ctrl+C to copy the entire slide to the Clipboard. 

 Click on the Window drop down menu, and select the other, open PowerPoint presentation, 
to which you wish to paste the copied slide. 

 Click on the Slide Sorter View icon (bottom-left), so that the slides of the second presentation 
are displayed in slide sorter view.  

 Click between the two slides where you wish to paste the copied slide (a thin vertical line 
marks the insertion point for you) 

 Press Ctrl+V to paste the copied slide. 
 
To change the background colour of the selected slide you have to:  
 

 Click on the Format drop down menu, and select the Background command. This will display 
a dialog box. Select the required colour. 

 To apply this background colour to the selected slide, click on the Apply button. 

 To apply this background colour to all the slides within the presentation click on the Apply to 
All button. 

 
 

Figure 52: Change the background of a selected slide 

3.3.1.7 Using Themes & Templates 
To apply a design theme:  

 Display the presentation to which you wish to apply a design theme. 

 Click on the Design tab and select the Themes submenu, which will display the available 
options. 

 



 
 
ViPi Project 511792-LLP-1-2010-1-GR-KA3-KA3NW  
 

www.vipi-project.eu Page 38 

 
Figure 53: Applying a design theme  

Finally, Master templates are basically used to create a new presentation. Click on the Office button, 
and then click on the New command. The New Presentation task pane is displayed. Then select the 
Installed Templates command. If you investigate the other options, such as Microsoft Office Online, 
you will see other available templates. Master templates help you impose a consistent look and feel 
on all the presentations. 

3.3.1.8 Add Media to a Slide  
If you want your presentations not to be static with unmoving images or text, you can add for 

instance movies and sounds to make them more exciting.  

To add a movie, click Insert from the PowerPoint tab bar at the top and select Movie or Sound to see 

the options: 

 
 

Figure 54: Insert movies and sound to your presentation 

PowerPoint seems to offer you a limited number of movies formats to insert. But AVI and MPEG 

videos should be OK. 
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After navigating to your video's location, and clicking OK, PowerPoint will display a message: 

 
 

 
 

Figure 55: Select the options “yes or no” for playing or not the video at your slide 

If you prefer not to play the video as soon as the slide appears on screen, click No. You would then 

have to click on the video itself for it to play. 

3.3.1.9 Saving a Presentation 
1. Click the Office Button and then select Save As to see the Save As dialog box. Ensure that you 

are located in the folder/disk drive of your choice by clicking the arrow to the right of the 
Save in drop down list box and navigating to your required location. 

2. Enter the filename in the File name text box. Filenames cannot include any of the following 
characters:  

 
Figure 56: Symbols that cannot be used as filenames 

3. Click the Save button to complete the file saving process. 

3.3.1.10 Closing a Presentation 
After you click the Office Button, select the Close menu OR click on the Close icon displayed at the 

top-right of the presentation window. 

The presentation will be closed and the screen will be cleared. If you try to close a presentation 

without saving it, PowerPoint displays a dialog box prompting you to save any of the changes you 

made to the presentation. 

3.3.2 Creating a SlideShow Presentation 

3.3.2.1 Add a New Slide with a specific Layout 
Click on the New Slide icon.  

 

Figure 57: The New Slide icon 
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From the Layout task pane, select the required slide layout (Figure 58). 

 

Figure 58: Slide Layout selections 

 
In the example illustrated, we selected the ‘Two Content’ slide layout. As you may see the slide is 

formatted accordingly (Figure 59). 

 
Figure 59: Formatting a slide 
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3.3.2.2 Apply a Different Layout to a Slide  
Display a slide within a presentation where you wish to change the slide layout. Right-click on the 

slide and from the popup menu, select the Layout command, as it is illustrated in Figure 60. 

 

Figure 60: Changing the Slide layout in PowerPoint 

This will display the Layout task pane and you could select the required slide layout. 

3.3.2.3 Save a Presentation in another Format 
To save a file in a format other than PowerPoint format, such as RTF:  

1. From the Office Button available options, click on the Save As command. 

2. If necessary, select the folder in which you wish to save the file from the Save in list box. 

3. Click on the down arrow to the right of the Save as type: box, and select the type of File 

format you wish to save the file as, such as PDF as it is shown in Figure 61. 

 
Figure 61: Saving a presentation in different file formats 
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3.3.2.4 Save File as a PowerPoint Template 
A template is a special type of file which can be created once and customized as required. It can then 

be recycled over and over again (Figure 62). 

 
Figure 62: Save files as a PowerPoint Template 

3.3.2.5 Switch Between Open Presentations  
Each presentation which you open will be displayed as an icon within the Windows Taskbar, 
(displayed along the bottom of your screen) as illustrated.  
 

 
 

Figure 63: Switching between different presentations 

To switch to the required presentation, you have to click on the icon.  

3.3.3 LibreOffice Impress 
Impress is the presentation editor for LibreOffice and with it you can create slide shows in its native 

formats odp and ppt and save presentations in PDF format for easy sharing. If you have installed 

LibreOffice, you have to select the “Presentation” option from the main menu:  

 

Figure 64: The presentation Option in LibreOffice 

You can start Impress in several ways: 

 If no component of LibreOffice is open, from the Start Center: click on the Presentation icon.  
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 From the system menu or the LibreOffice Quickstarter. Details vary with your operating 
system; see Chapter 1 in the Getting Started guide if you need more information. 

 From any open component of LibreOffice: click the triangle to the right of the New icon on 
the main toolbar and select Presentation from the drop-down menu, or choose File -> New-> 
Presentation from the menu bar. 

When you start Impress for the first time, the Presentation Wizard is shown. If you prefer not to use 

the wizard in future, you can select Do not show this wizard again. Click Create to open the main 

Impress window. 

 

Figure 65: The Presentation Wizard Window 

In the next screen capture you´ll have to select among different presentation backgrounds (Figure 

66).   

 

Figure 66: Select among different presentation backgrounds 
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Select the create option a window with layouts options will open. Now you have to go to the Layouts 

task panel and select one of them, as it is shown in Figure 67.  

 

Figure 67: The Task panel of “Layouts” 

The main Impress window has three parts: the Slides pane, the Workspace, and the Tasks pane. You 

can remove the Slides pane or the Tasks pane from view by clicking the X in the upper right corner of 

each pane. You can also show or hide these panes using View -> Slide Pane or View -> Task Pane or 

by clicking the Hide/Show marker in the middle of the vertical separator line (circled in illustration). 

By hiding these panes, you can maximize the Workspace area. 

 

Figure 68: The main Impress Window 

The Slides pane contains thumbnail pictures of the slides in your presentation.  Clicking a slide in this 

pane selects it and places it in the Workspace. When a slide is in the Workspace, you can change it in 

any way you like. 
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 Tasks pane. The Tasks pane has five sections: Master Pages, Layouts, Table Design, Custom 

Animation, Slide Transition  

 Master Pages: Here you define the page style for your presentation. 

 Layouts: You can choose the one you want and use it as it is, or you can modify it to meet 

your own requirements. 

 Table design: The standard table styles are provided in this area 

 Slide Transition: The Slide Transition section provides access to a number of slide transition 

options. 

The Workspace (normally in the centre) has five tabs, also called View buttons. 

 

Figure 69: The Workspace’s menu 

Toolbars: Many toolbars can be used during slide creation; they can be displayed or hidden by 

clicking View > Toolbars and selecting from the menu. 

Status bar: The status bar, located at the bottom of the Impress window, contains information that 

you may find useful when working on a presentation. 

Navigator: The Navigator displays all objects contained in a document. It provides another 

convenient way to move around a document and find items in it.  

 

Figure 70: The Navigator functionality 

To enter some text, just follow the instructions into the box: “Click to add title” as it is shown in 

Figure 71. 
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Figure 71: Adding title and text in a presentation in LibreOffice 

To insert images you have to create a new presentation and then create a blank slide as it is shown in 

Figure 72, where you are going to inert the image which you have stores in your folders (i.e. your 

desktop or My Pictures folder, etc.).  

 

Figure 72: Inserting images in LibreOffice Impress 

When you create a new presentation you can add some style to it. So, suppose you have the title 

below “The LibreOffice features” and you want to present it in a more impressive way. To achieve 

this, go to the left panel and click on Master Pages. It will show you the available options as it is 

shown in Figure 73:  
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Figure 73: The Master Pages options for applying styles in presentations 

When no document is open, the Start Center provides an icon for opening an existing document or 

choosing from a list of recently-edited documents. 

 

Figure 74: Opening an existing document in LibreOffice 

You can also open an existing document in one of the following ways. 

 Choose File → Open... 

  Click the Open button on the main toolbar. 

 Press Control+O on the keyboard. 

In each case, the Open dialog appears. Select the file you want, and then click Open. To close a 

document, choose File → Close. You can also close a document by clicking on the Close icon on the 

document window.  

To close a document, choose File → Close. You can also close a document by clicking on the Close 

icon on the document window. 

 

Figure 75: The Close command in LibreOffice 
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If more than one LibreOffice window is open, each window looks like the sample shown on the left. If 

only one LibreOffice window is open, it looks like the sample shown on the right. If the document has 

not been saved since the last change, a message box is displayed. Choose whether to save or discard 

your changes. 

 Save: The document is saved and then closed. 

 Discard: The document is closed, and all modifications since the last save are lost. 

 Cancel: Nothing happens, and you return to the document.  

 

To close LibreOffice completely, choose File → Exit.   

A new presentation only contains one empty slide. To insert slides you have to:  

  Insert > Slide. 

 Right-click on the present slide, and select Slide > New Slide from the pop-up menu. 

 Click the Slide icon in the Presentation toolbar.  

 

 

Figure 76: The Presentation toolbar in LibreOffice 

Sometimes, rather than starting from a new slide you want to duplicate a slide you have already 

inserted. To do so select the slide you want to duplicate from the Slides pane and then choose Insert 

-> Duplicate Slide.  

To select a layout:  

In the Tasks pane, select the Layout drawer to display the available layouts. The Layouts differ in the 

number of elements a slide will contain, from a blank slide to a slide with six contents boxes and a 

title. 

 

Figure 77: Selecting the layout in Task pane 
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The first slide in a presentation is normally a title slide. The Title Slide (which also contains a section 

for a subtitle) or Title Only are suitable layouts for the first slide, while for most of the slides you will 

probably use the Title, Contents layout. To create the title, click on Click to add title (assuming the 

Blank Slide layout was not used) and then type the title text. To adjust the formatting of the title, 

modify the Title presentation style;  

If you want to change the appearance namely the background of all slides in the presentation, you 

have to modify the slide master or choose a different slide master. A Slide Master is a slide with a 

specified set of characteristics that acts as a template and is used as the starting point for creating 

other slides. These characteristics include the background, objects in the background, formatting of 

any text used, and any background graphics. 

Impress has a range of prepackaged slide masters, found in the Master Pages section of the Tasks 

Pane. However if you want to change the background, you can take a shortcut: 

 Select Format > Page and go to the Background tab. 

 Select the desired background between solid color, gradient, hatching, and bitmap. Click 

 OK to apply it. 

To set up a new presentation using the Presentation Wizard: 

1. Under Type, choose one of the options: 

• Empty presentation creates a blank presentation.  

• From template uses a template design already created as the basis for a new 

presentation. The wizard changes to show a list of available templates. Choose the 

template you want.  

• Open existing presentation continues work on a previously created presentation. The 

wizard changes to show a list of existing presentations. Choose the one you want.  

2. Click Next.  

3. Choose a design under Select a slide design. The slide design section gives you two main 

choices: Presentation Backgrounds and Presentations. Each one has a list of choices for slide 

designs. If you want to use one of these other than <Original>, click it to select it.  

4. Select how the presentation will be used under Select an output medium. Most often, 

presentations are created for computer screen display, so you would select Screen. You can 

change the page format at any time.  

5. Click Next. The Presentation Wizard step 3 appears. Choose the desired slide transition from 

the Effect drop-down menu. Select the desired speed for the transition between the 

different slides in the presentation from the Speed drop-down menu. Medium is a good 

choice for now.  

6. Click Create. A new presentation is created.  
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3.4 Online learning environments 
E-learning is emerging as a new paradigm of modern education. Online management of knowledge 

and sharing of information helps guarantee the right of people to access knowledge in a simple and 

accessible way. In the sections below we will indicate the potential of: 

 Available online resources for creating and collaborating on documents. 

 Popular E-learning systems (particularly ATutor & Moodle) and what they have to offer. 

 The extent to which e-learning applications can be used to achieve specific goals with 
effectively and efficiently in a specified context of use. 

On-line environments develop and implement technology in order to engage users in more exciting 

new ways, reaching them on their terms and devices and keeping them informed, involved and 

collaborating together. 

3.4.1 ATutor 

3.4.1.1 Overview 
ATutor is a free Web-based LMCS- Learning Content Management System designed to be a teaching 

and learning tool which can be placed either on the Internet or within an organization’s intranet. The 

ATutor community is very supportive. A number of modules exist that extend ATutor’s features and 

may enable learners and teachers to chat, collaborate, create accessible forms and surveys, practice 

instant messaging, conduct white board presentations of educational material, and more. 

A Tutor supports the accessibility standards that are quoted below: 

 W3C WCAG 1.0 

 W3C WCAG 2.0 

 3C ATAG 2.0 

 US Section 508 

 Italy Stanca Act 

 IMS AccessForAll 2.0 

 ISO/IEC 24751 
 
Moreover it supports the following Interoperability standards:  

 OpenSocial 1.0 

 OAuth Authentication Protocol 

 IMS Content Packaging 1.1.2+ 

 SCORM Content Packaging  

 SCORM 1.2 LMS RTE3  

 IMS Question Test Interoperability (QTI) 1.2/2.1 

 IMS BasicLTI 1.0 (reg. IMSB2ar2011W1) 

 IMS Common Cartridge 1.0 (reg. IMSA2ar2011W1) 

 W3C XHTML 1.0 
 

http://www.w3.org/WAI/GL/WCAG20/implementation-report/implementation?implementation_id=47
http://www.imsglobal.org/ProductDirectory/productdirectory1.cfm?auto=1326
http://www.imsglobal.org/ProductDirectory/productdirectory1.cfm?auto=1326
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3.4.1.2 Login and Registration 
Since ATutor is learner-centred, courses and communication links are dedicated to educational 

interaction on an individual basis. One of consequences of this approach is that each student must 

have a separate account in which personalized data, lectures, records, communication logs, and 

educational materials designed for that course (and very often for that particular student) may be 

held. Particularly, increased confidentiality during the educational process is required for students 

with disabilities and specific cultural needs.  

Each student must open an account with a login and password. The first page the student sees is a 

login page where the student either logs in or registers to create an account (if the student is visiting 

the login page for the first time). In case he/she forgets his/her password, may click on “Forgot your 

password?” and typing the user's e-mail address to which the password will then be sent.  

 

Figure 78: ATutor login & registration page 

To register for the first time a student has to enter personal details so she/he may be easily identified 

by the course instructor and administrator when necessary. 

Students may login by typing their login name (or email address) and password and enter the ATutor 

installation on a given server via a web browser. Students will be presented with “My Courses” 

screen that does have on top links to Browse Courses and Create Course screen.  
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Figure 79: ATutor registration details 

3.4.1.3 Profile and Preferences 
Profile and Preferences tabs are available on the page. A student may change in tab Profile his/her 

profile data whereas in tab Preferences they can change some basic preferences concerning inbox 

notification, auto-login features, type of content editor, topic numbering etc. Students may see a list 

of courses that are available when pressing the link Browse Courses on the My Courses screen. 
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Figure 80: ATutor “My Start Page” 

3.4.1.4 Browse Courses 
The screen Browse Courses is divided in three columns: the column of the Browse Courses screen 

that provides a list of course categories, the column with a list of courses within a selected category, 

and the third one which informs students in detail about the selected course. In each course data is 

displayed such as the name of the course, name of the instructor with the possibility to contact the 

course instructor and the type of access of a respective course. 

Pressing the Contact Course Instructor link the user will be prompted with a form to send an E-mail 

message to the course instructor. Access to the courses may be protected or public. In the latter case 

access may be permitted without going through the login procedure. 

3.4.1.5 Creating Courses & Setting Preferences 
When an administrator logs in they are shown a list of menus and sub-menus presented as 

hyperlinks. They may be accessed just by clicking on the proper hyperlink, tab or by pressing the keys 

Alt+ 1, Alt+2, Alt+3, Alt+4, or Alt+5 that are assigned for the tabs from left to right. It is very 

important that key shortcuts are defined in that way since even people with certain disabilities may 

administer ATutor. 
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3.4.2 Moodle 
Moodle is a free web application that educators can use to create online learning sites. Moodle 

features “modular” design using modular object-oriented dynamic learning environments. Moodle 

was developed to help educators to create online courses with a focus on interaction and 

collaborative construction of learning.  

Dynamic learning tools are available through Moodle. This open source tool is based on the social 

constructionist pedagogy – This is defined as active learning in a social context, taking place in a 

learning environment with smart and interactive tools.  

Moodle has several features considered typical of an e-learning platform, plus some original 

innovations (like its filtering system). Some typical features of Moodle are presented in the sections 

that follow. 

3.4.2.1 Assignment Submission 
There are four standard assignment types, but there are several other contributed assignment types 

which can be downloaded from the modules and plugins database.  

 

Figure 81: Moodle assignment options 

 Advanced Uploading of files: students can submit one or several items such as word-

processed documents with a note to their teacher. The teacher can comment on and send 

back the uploaded file. 

 Online text: students can type their response directly into Moodle using the Text editor 

 Upload a single file: students typically submit one piece of work such as a word-processed 

document or presentation 

 Offline assignment: not a "true" assignment but a place for a teacher to add grades to work 

done outside of Moodle. 

Students can submit their assignments with the Upload a Single file and Advanced uploading of file 

assignments. A button “upload file” will take them to the file picker where they locate their files.  

 

Figure 82: Submit an assignment 

http://moodle.org/plugins/browse.php?list=category&id=12
http://docs.moodle.org/22/en/Text_editor
http://docs.moodle.org/22/en/File:Assignmentdropdown.png
http://docs.moodle.org/22/en/File:Studentupload.png
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3.4.2.2 Discussion Forum 
A discussion forum enables participants to communicate online using text. Moodle allows tutors to 

set up and configure online forums for groups or sub-groups of students, which can include text and 

other media. Forums are useful, and can be used as follows:  

 As a group formation and bonding “check-in” space at the beginning of a course.  

 A class teacher can indicate a reading and ask an open question, e.g. "for comments".  

 A class teacher can post documents with specific questions to be answered re the material.  

 When students are required to post presentation material prior to a seminar with or without 

inviting peer evaluation.  

 For mutual support and/or collaborative learning where students are physically remote – on 

placements for example, and risk feeling isolated  

 When there is a need to record contributions or thought processes 

3.4.2.3 File Download 
The File download portfolio allows for easy download of content in Moodle activities. To enable file 

download:  

 Go to Settings > Site administration > Plugins > Portfolios > Manage Portfolios 

 Select from the drop down next to File download "Enabled and visible"; 

 

Figure 83: Download a file 

You have to click on the “Settings” and optionally give File download a customised name.  

3.4.2.4 Grading 
A grade item is a unit (typically an activity) where course participants are assessed through a grade or 

mark. As such, a grade item is a container for grades and a set of settings applied to these grades. 

3.4.2.5 Instant Messages 
Most of the interaction takes place in a small window that looks like an IM window (which you can 

expand to a desired size). It contains several tabs to let you switch between messaging a user, 

searching for users and reading archived messages. 

It pops up (or to the front) whenever: 

 you click on a name in the online users list  

 you click on a link on any participants page  

 you click on a general link in the participants block  

http://docs.moodle.org/22/en/File:Filedownloadenabled.png
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 you have a new message sent to you  

3.4.2.6 Online Calendar 
The calendar can display site, course, group and or user events in addition to assignment and quiz 

deadlines, chat times and other course events. 

 

Figure 84: Moodle online calendar 

3.4.2.7 Online Quiz 
Moodle is a template-based system to which content must be is added. Its interface is intuitive and 

easy for navigation. The whole page is presented in a "flat view" format. As Robb (2004) describes it, 

this is different from other systems that often make use of "Chinese boxes" with content inside 

folders at various levels. Each section has its own tools such as lessons, quizzes, assignments, and 

forums in order to enhance students’ view. 

Access to nearly all lesson assignments can be made time- or password-restricted. Moodle also saves 

automatic log reports of students work in an individual level. Therefore the teacher is informed not 

only about the time that students have completed or uploaded an assignment, but also the time that 

they spent on an assigned task or quiz. 

The quiz module includes the following response types: fill-ins, multiple-choice, multi-choice (more 

than one answer can be selected), true-false, matching, short-answer (exact matching). All types are 

supported with automatic tallying and scoring, based on teacher or student-determined rating scales. 

3.4.2.8 Wiki 
Students can be divided into subgroups, interact with each other synchronously in chat rooms, or 

engage in asynchronous discussions in Wikis and forums. The Wiki module in Moodle enables 

students to compose or work together on a text while online. 

 A wiki (the word is Hawaiian for ‘quick’!) is a series of web pages on the Internet that can be 

immediately and easily edited by anyone with a password to the wiki. They are collaborative spaces 

online where you can share and create information among a number of users. 

Some wikis do not require a password and are open to the general public (www.wikipedia.org). 

http://www.wikipedia.org/
http://docs.moodle.org/22/en/File:Calendar_full_screen_1-9a.png
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A wiki is collaborative, as it can be updated and edited by several people. The content of a wiki 

depends on you.  

1. Getting started with your wiki 

Several different sites offer free wiki services, but one of the easiest to use is pbwiki (Short for 

‘peanut butter wiki’ – “Easy as a peanut butter sandwich”, says the pbwiki site).  

 To create a wiki in pbwiki, go to www.pbwiki.com, and you will see this screen.  

 

Figure 85: Creating a wiki in pbwiki 

Give your wiki a name, which will be its web address. The wiki in the screenshot is called 

etwinningwiki – note that your wiki name must have no spaces, and can consist of letters and/or 

numbers.Then type in your email address, and click on ‘Make a wiki’. The screen below will appear: 

 

Figure 86: “Making a wiki” 

Confirm your wiki and set a password. Afterwards an email will be sent to your mail address asking 

you to click on a link to set your wiki’s password. The email is like Figure 87. 

http://www.pbwiki.com/
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Figure 87: Set your wiki’s password 

Follow the instructions, by clicking on the link in the email, and you will be taken to a page where you 

can set the password for your wiki. You have to type your password in the ‘Pick a password’ box, and 

again in the ‘Confirm password’ box. You have to note down and remember your wiki password! If 

you prefer not to make your wiki available to the public, uncheck the box that says ‘Make my wiki 

public’. Click on ‘Take me to my wiki’. 

2. Edit your wiki front page. The front page of your wiki, currently looks like this:  

 

Figure 88: Editing your wiki 

You have to click on the blue button with the instruction ‘Edit this page’ on the bottom left of the 

screen. The Welcome information follows, so you can now delete it all, and replace it with an 

introduction to your own wiki. 
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3.5 Practical Exercises 

3.5.1 An example of purchasing, using Amazon.co.uk 
Search for Amazon on Google. Go to Google.co.uk and type Amazon and hit the magnifying glass 

search button. 

 

Figure 89 : Finding Amazon using Google 

Click on the link to be directed to the Amazon.co.uk homepage 
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Figure 90 : Signing up as a new customer 

You will need to register as an amazon user. To do this you need an email address. Fill in your email 

as in the example above and ensure ‘no, I am a new customer is checked’. Click sign in using secure 

server. 
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Figure 91 : Creating an Amazon account 

You will now notice the https:// has appeared at the start of the URL accompanied by a lock symbol. 

This capture is from Google Chrome, so yours may look slightly different, but it should still be 

displaying the https and a lock symbol. 

Enter a password, and enter it again in the second box. This is to ensure you typed it correctly. Click 

on create account. 
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Figure 92 : The new customer welcome page 

You will now enter Amazon as a logged in user. Note that this is now NOT a secure page (No ‘https’ 

or lock symbol present). Note also the window says ‘Hello Andy Bloggs we have recommendations 

(not Andy?)’. (Andy Bloggs should be replaced by the name you entered.) Recommendations are not 

useful as yet, but as you use Amazon, its intelligent search will try to recommend items in which it 

thinks you may be interested, based on what you have looked at before. As a new customer you can 

customise your shopping experience by telling Amazon your interests, or just get on and search for 

what you want to buy as we will do next. 
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Figure 93 : Typing a search into the search bar - in this case we want to find music by the band "New Model Army" 

In Figure 93 we see that the search bar has some text entered in it. Try this yourself and hit the go 

button. 
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Figure 94 : The results of the search 

You should get a list of search results much like the one in Figure 94. Each item listed has a summary 

of info about it. How much it costs, and from which seller, what it is – in this case Audio CD, a star 

rating, telling you what other buyers thought of the product, and what delivery options would be 

available. 
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Figure 95 : Examining the details of a product 

Clicking on one of the items in the list allows you to examine it more closely (like in Figure 95). This 

may provide multiple images, details of when it will be available, a more detailed description of the 

item, reviews by other buyers if available, or a full specification of the item. 
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Figure 96 : Adding the item to your shopping basket 

Clicking on the ‘Add to basket’ item places the item, ready for buying, into a virtual shopping basket. 

Once in the shopping basket, items are saved ready for you to check out later. More items can be 

added and items can be easily removed from the basket. 
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Figure 97 : Viewing the shopping basket 

You will see that the basket icon near the search bar now has a 1 in it representing the 1 item in your 

basket. We can click this button to see the shopping basket, and to remove items from it if we so 

desire. Clicking the Proceed to checkout button will move us on to buy what is in our shopping 

basket. 
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Figure 98 : checking out - firstly signing in to 'secure server' 

The first stage before checking out is logging on again to the secure server. This process allows the 

website to encrypt the sensitive data you may be sending such as your address or card details. In 

Figure 98 we can now use the second option of ‘I am a returning customer’ and log in using our 

password created earlier. 
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Figure 99 : Entering the delivery details 

After logging back in we need to enter our address. It is important this is correct as it is where goods 

and invoices would be sent. Usually for a first purchase, the goods must be sent to the address at 

which the credit card is registered, so bear this in mind for your first purchase. 
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Figure 100 : Filling the form in 

The form can be filled in using the mouse to select fields to type in, or by using the tab button to 

move between fields. Click on continue when all data is entered. If you have missed and data or 

made an error, the form may notice and ask you to rectify it. 
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Figure 101 : Selecting the postage options 

Amazon offers multiple posting options which you can select depending on the urgency of the 

purchase. The free delivery is often slow, but a more expensive next day delivery may be available. 
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Figure 102 : Entering card details 

Finally the payment details are requested. This entails entering the long card number from your card, 

the expiry date, start date or issue number and often the 3 number security code from the back of 

the card. Always ensure you are using a secure HTTPS connection before entering such details onto a 

website. 
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Figure 103 : Final review screen before check out 

Finally in Figure 103 we see that Amazon offers a final opportunity to check what you are purchasing, 

where it is going and by what method at what cost. Clicking the ‘Place your order’ button will finalise 

the purchase. ONLY DO THIS IF YOU REALLY WANT TO PURCHASE THE ITEM! 
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Figure 104 : Confirmation of order screen 

If you do press the ‘confirm your order’ button, you will be shown to a confirmation page as in Figure 

104. This will contain the number of the order in case you need it for future reference in case of any 

problem with the delivery or of a faulty product – or should you just decide to return the item. All of 

these details will also be emailed to the email address given at log in for your records, and all the 

details are also stored securely within Amazon’s system. 

This process is similar to that used on many online stores, and it will allow you to purchase goods and 

services from a wide variety of suppliers. Always ensure that a site is reputable before attempting to 

purchase goods from it. The security certificate should be valid. This may be checked by clicking on 

the lock icon in the URL bar. Please refer to the WEB Security notes of the course in sections 2.6 and 

2.12 for further details on this. 


